• Home
  • WD Hard Disk not Working

Here are the causes for the WD Passport hard disk nt working on your device.

WD Passport Hard Disk Not Working
  • Faulty USB cable.
  • Faulty power cable.
  • Obsolete/outdated WD driver.
  • Outdated USB driver.

Follow the methods described here to fix the WD Passport hard disk not working issue.

Method 1- Unplug the Cable Connection

  • Go to the Control Panel on your Windows computer.
  • Select Devices and Printers in the Control Panel.
  • Find and select the Passport drive and open the properties.
  • Open Drivers and uninstall it from your device.
  • Unplug the WD Passport hard disk and restart your device.
  • Plug in the hard disk again and check whether you still face any problem. If yes, then go to the next method.

Method 2- Try with an Alternative USB Cable

  • Remove the USB cable used to connect the WD hard disk to your computer.
  • Connect the hard disk to another USB port on your computer using the same USB cable.
  • If the hard disk works now, then the USB port to which the hard disk was connected earlier is defective.
  • If the hard disk doesn’t work, then connect the disk using a new USB cable and check if the issue is fixed.

Method 3- WD Drive Letter

  • Open the Run dialog window by pressing the Win + R keys.
  • Type diskmgmt.msc in the Run command window and press Enter.
  • On the Disk Management window, right-click on the WD drive and selects the Change Drive Letter and Paths option.
  • Click the ADD button to assign a drive letter.
  • Select the drive letter from the menu and complete the process.
  • Restart the device and check if the WD hard disk is working now.

Method 4- Reboot the System

  • Go to the Settings on your computer and choose Update and Security option.
  • Click on the Recovery tab and select Advanced Setup.
  • Now click on the Restart button.
  • Make sure to press F4 to boot in safe mode.
  • Check if the WD hard disk works when connected in safe mode.

Now you have seen how to fix WD Passport Hard Disk not working issue.